I find that
to
instead of
hlint
is a great tool for pointing out where your code can be improved, but sometimes its suggestions are... interesting. Case in point, it just recommended changingmap (\(a, b) -> {- ...stuff... -}) $ zip as bs
to
zipWith (curry (\(a, b) -> {- ...stuff... -})) as bs
instead of
zipWith (\a b -> {- ...stuff... -}) as bs